Authenticator bug [Merged]

Authenticator bug [Merged]

in Account Issues

Posted by: Dogblaster.6713

Dogblaster.6713

Hello,

So I have authenticator linked with my gw2 account. Untill today everything was fine, with every single login ive done I was asked for the authentication code. But after todays patch I can log in to my account without it, It doesnt require the authentication code, not even to the website even when it should.

Is this some kind of bug or what?

Please fix this.

(edited by Moderator)

Authenticator bug [Merged]

in Account Issues

Posted by: Ulquiorra.6903

Ulquiorra.6903

i do not know if this is the right sub fora to post this but after the patch i noticed the mobile auth isnt working as in when i try to logg on it no longer asks me to authenticate. i even tried resetting it up again but it just does not work. i do not know if it is just me but x.x

Authenticator bug [Merged]

in Account Issues

Posted by: tertle.4621

tertle.4621

Friend has the same issue his authenticator appears attached but it doesn’t appear when logging in. He also can’t remove it.

I personally have no problem with mine though.

Authenticator bug [Merged]

in Account Issues

Posted by: OvaltinePirate.6579

OvaltinePirate.6579

I am having the same issue, authentication is no longer required to log in to the game or the website. I also cannot remove my authenticator through the security tab on the website.

Authenticator bug [Merged]

in Account Issues

Posted by: frikandel.9013

frikandel.9013

i am got the same problem here

Authenticator bug [Merged]

in Account Issues

Posted by: DrHarvey.2583

DrHarvey.2583

Me too. Have the mobile authenticator but it lets me log in without needing to enter a code.

It also won’t let me unlink the authenticator.

Authenticator bug [Merged]

in Account Issues

Posted by: Nazdravan.1847

Nazdravan.1847

Same issue but I could remove and re add an authenticator. What is some what concerning is that my account is unprotected while in this state.

Any sufficiently advanced technology is indistinguishable from magic.

Authenticator bug [Merged]

in Account Issues

Posted by: Swagart.6315

Swagart.6315

I am experiencing this issue as well. My authenticator is still linked to my account though.

Authenticator bug [Merged]

in Account Issues

Posted by: Rykos.8643

Rykos.8643

I am having the same issue. My authenticator is still linked to my account.

Authenticator bug [Merged]

in Account Issues

Posted by: Dewuxe.1854

Dewuxe.1854

I guess I have someway the same issue, I want to unlink it so get a new main code,
to write down because now it’s linked to the plugin in google chrome for the authentication, but its a bit hard then to log in in different places without knowing the main code for my authenticator.

Authenticator bug [Merged]

in Account Issues

Posted by: Barrywmartin.6523

Barrywmartin.6523

Last night I was in game (often) and had to use my authenticator serial to log into the GW2 client (as usual). This morning when I tried to log into both the forum and the game, I was not presented with the authenticator window. I read the forum for new information about updates or procedures and did not find any news about this. Has there been a change in how the authenticator works or is there a way to verify that I am authenticated. I simply would rather have the peace of mind of having the extra layer of security before I log back into the game.

Also, when I checked my account on the GW2 website, it states that my account is linked with the authenticator (as it should be). Is anyone else getting this.

Authenticator bug [Merged]

in Account Issues

Posted by: Zaken.1806

Zaken.1806

I just tried it and it didn’t ask for the code either. I also couldn’t find anything on the patch note.

Authenticator bug [Merged]

in Account Issues

Posted by: Jokulan.2175

Jokulan.2175

Same problem here. I think that newest patch somehow broke it?

Authenticator bug [Merged]

in Account Issues

Posted by: Hellekin.2759

Hellekin.2759

also bypassing the authentificator on the german client… pls fix that immediately!

Authenticator bug [Merged]

in Account Issues

Posted by: Myrkaba.9643

Myrkaba.9643

Same issue here as well. US client.

Authenticator bug [Merged]

in Account Issues

Posted by: Zaken.1806

Zaken.1806

While I appreciate moderator merged the thread, can we also get some sort of info on the situation ?

Is ANet informed of this issue ?
Is it a new feature ?
Is it a bug ? If so, is ANet doing anything at the moment to protect hacking ?

Can we get some direct info from ANet ?

Authenticator bug [Merged]

in Account Issues

Posted by: Moderator

Moderator

Hi,

Merging the thread help keeping it clear and visible for other users experiencing this issue and for us in order to analyse it.

Yes indeed posting on these forums means you are informing us.

Please keep reporting, and keep an eye here.

Thanks for your patience and understanding.

(edited by Moderator.9672)

Authenticator bug [Merged]

in Account Issues

Posted by: Zaken.1806

Zaken.1806

At least now we know it’s a bug. I hope ANet can patch it before any lose control of their account since email authentication is disabled with authenticator. Good luck everyone

Authenticator bug [Merged]

in Account Issues

Posted by: RamonDomke

RamonDomke

German Community Manager

Next

We are aware of this issue and are working to fix it.

Authenticator bug [Merged]

in Account Issues

Posted by: ThFH.6048

ThFH.6048

Thanks I noticed the problem it also doesn’t ask for a code when you login to the site or forums.

Authenticator bug [Merged]

in Account Issues

Posted by: Zaken.1806

Zaken.1806

Thank you RamonDomke!

Authenticator bug [Merged]

in Account Issues

Posted by: KatiesAura.5928

KatiesAura.5928

bit wierd but neither site or game askess for authentication when linked but has Ramon said theyre trying to fix, possibly a new patch in next few hours will fix it

Authenticator bug [Merged]

in Account Issues

Posted by: MikeLewis

Previous

MikeLewis

Security Coordinator

Next

Hi all,

First and foremost: please be aware that your accounts are still protected by the mobile authenticator at this time.

Here’s what has happened:

- We have been developing a “remember this network” feature for the mobile authenticator in line with the same feature used by email authentication

- This feature became active tonight during the planned maintenance updates

- For any account which has already selected to remember a network, the mobile authenticator will respect your existing settings

- This means that if you are logging in from a location that you permitted via email authentication, the mobile authenticator will not currently prompt you for a secondary code

Your account is still covered by the authenticator for logins from unverified locations.

This is the result of an oversight on my part and I’d like to apologize for any uncertainty and worry. We’ve double checked the systems and authentication is working correctly for unverified logins.

Unlinking the authenticator was temporarily disabled due to a configuration accident; this has been corrected and should work again.

For the moment we do not have a user interface for editing your “remembered” network locations. As a result, please be very cautious when selecting to allow new locations from the emails (or, in the near future, from the mobile authenticator login screen).

Thanks for bearing with us while we get the rest of the mobile authenticator features ready to go.

Authenticator bug [Merged]

in Account Issues

Posted by: Zaken.1806

Zaken.1806

Thank you MikeLewis for the update. I am sure that makes a lot of us feel better with such timely update. I greatly appreciate it.

Authenticator bug [Merged]

in Account Issues

Posted by: marcvanwake.7305

marcvanwake.7305

thank you mike

Authenticator bug [Merged]

in Account Issues

Posted by: Magistrella.6970

Magistrella.6970

What if we still want to keep the authenticator active at all times because we are a paranoid bunch of scaredy cats? ^o^

Personally i’d like to still have it as im logging in from a student dorm where like 20 or 30 people share the same network ip, and i have no clue if any other resident plays GW2 as well and/or has no good intentions etc. etc.

Putting in 6 numbers is no big deal for me, but for others it seems so, so could you give us an option for “always ask for authenticator” and “Only use Authenticator on not remembered networks” or so?

Really appreciating the work you put in the game and the stuff around, keep it up (‘-’)/ Greetz from Germany~

Authenticator bug [Merged]

in Account Issues

Posted by: Chibi.1839

Chibi.1839

Thank You
I was wondering why it didn’t ask for the code. Now i know why

Authenticator bug [Merged]

in Account Issues

Posted by: Ari Kagura.9182

Ari Kagura.9182

Thanks for the clarification, Mike. I guess that explains why I wasn’t prompted for my authenticator code when I logged on to the game and forums.

Personally, I’d like to have the option to always ask me for the 6 digit code regardless of where I go to log into my account. I guess I’m just paranoid like that, but I suppose it’s interesting to know I have an option to remember certain networks.

“I control my fate!” — Claire Farron
I am Fleeting Flash, in-game dungeon cosplayer of Reddit Refugees [RR] .

Authenticator bug [Merged]

in Account Issues

Posted by: GADefence.5634

GADefence.5634

Mike, can you explain to me why the e-mail authenticator seems gone now that the mobile one is up? I don’t have a mobile phoen and hence no mobile indicator, so I’m curious as to why I don’t have my e-mail indicator.

Authenticator bug [Merged]

in Account Issues

Posted by: Captain Ianus.2654

Captain Ianus.2654

i downloaded the mobile Authenticator for the IPhone and used it successfully for several weeks, and then today it stopped being required for logging in to my account. i unlinked the authenticator app and relinked it, but it still wasn’t working. i deleted the app and relinked my account to my mobile authenticator but it still isn’t asking me for the six-digit code after i log in. is this a change in account security parameters or is it a bug?
many thanks

Authenticator bug [Merged]

in Account Issues

Posted by: TheRabbit.9478

TheRabbit.9478

i downloaded the mobile Authenticator for the IPhone and used it successfully for several weeks, and then today it stopped being required for logging in to my account. i unlinked the authenticator app and relinked it, but it still wasn’t working. i deleted the app and relinked my account to my mobile authenticator but it still isn’t asking me for the six-digit code after i log in. is this a change in account security parameters or is it a bug?
many thanks

Read 7 posts above yours:

Hi all,

First and foremost: please be aware that your accounts are still protected by the mobile authenticator at this time.

Here’s what has happened:

- We have been developing a “remember this network” feature for the mobile authenticator in line with the same feature used by email authentication

- This feature became active tonight during the planned maintenance updates

- For any account which has already selected to remember a network, the mobile authenticator will respect your existing settings

- This means that if you are logging in from a location that you permitted via email authentication, the mobile authenticator will not currently prompt you for a secondary code

Your account is still covered by the authenticator for logins from unverified locations.

This is the result of an oversight on my part and I’d like to apologize for any uncertainty and worry. We’ve double checked the systems and authentication is working correctly for unverified logins.

Unlinking the authenticator was temporarily disabled due to a configuration accident; this has been corrected and should work again.

For the moment we do not have a user interface for editing your “remembered” network locations. As a result, please be very cautious when selecting to allow new locations from the emails (or, in the near future, from the mobile authenticator login screen).

Thanks for bearing with us while we get the rest of the mobile authenticator features ready to go.

Authenticator bug [Merged]

in Account Issues

Posted by: Syphen.1980

Syphen.1980

Thanks. I was panicing there for a minute.

Authenticator bug [Merged]

in Account Issues

Posted by: Jorn Wolfgang.3712

Jorn Wolfgang.3712

I too would like an option to keep using it every login. I can spare the two seconds to input 6 digits.

Authenticator bug [Merged]

in Account Issues

Posted by: bpphantom.8243

bpphantom.8243

Is there a way to have it for the game and when accessing account information, but not just the forums?

“Do what you can, with what you have, where you are. Then leave the rest to Batman.”

Authenticator bug [Merged]

in Account Issues

Posted by: Grithan Soulforge.5726

Grithan Soulforge.5726

Please give us the option to trust NO networks. I strongly prefer entering the code every time.

The idea of random wireless networks such as Starbucks being automatically trusted or being on an ISP with multiple non-contiguous DHCP IPv4 ranges in my area makes me wonder if I should disable the authenticator as it’s only giving an illusion of security.

Authenticator bug [Merged]

in Account Issues

Posted by: basse.2510

basse.2510

Im used to authenticators as i use it both in wow and swtor or well when i still played those games. And i dont mind to write the code everytime i log in. It takes only few seconds. Another thing i found out about it first today (the authenticator) that GW2 use one (i know im blind :-P ) but while setting it up the google authenticator dosent accept the QR code when i try to scan it. I manage to set it up somehow without it ( hope its working)its showing under security tab on the site that i have one attached. But it didnt asked for the code? shouldnt it do the first time?? or is it still because i have allready verified the computer back when email verification was the only solution?.

Authenticator bug [Merged]

in Account Issues

Posted by: cold.3946

cold.3946

Hey Mike,

Thanks for the update. Can you post a stick announcement on the forums somewhere – or better yet on the client news/announcements area. I’m sure it will help reduce panic for other players.

Keg – 80 Guardian | Mini Keg – 80 Mesmer
Strike Force [SF] Stormbluff Isle
www.strikeforceguild.com

Authenticator bug [Merged]

in Account Issues

Posted by: Twelves.2013

Twelves.2013

I was using the authenticator and removed it from my account last week b/c I was tired of having my phone every time I logged on. After seeing the dev post above about trusting a network I tried to set it up again. Now when I scan the QR code (iphone app) it tells me the token is invalid. Not sure if that has to do with me being previously setup or just how the account + google handshake is happening. Is anyone else having that problem?

Authenticator bug [Merged]

in Account Issues

Posted by: Jaglavak.5806

Jaglavak.5806

Yet another reason for ArenaNet to put a little more effort in to the patch notes.

Jaglavak – Asura Elementalist + 7 alts / Server: Seafarer’s Rest

Authenticator bug [Merged]

in Account Issues

Posted by: Zaken.1806

Zaken.1806

@Jaglavak

The feature wasn’t suppose to be enabled hence it is not included in the patch note.

Authenticator bug [Merged]

in Account Issues

Posted by: Ieyasu.4096

Ieyasu.4096

- This means that if you are logging in from a location that you permitted via email authentication, the mobile authenticator will not currently prompt you for a secondary code

I allowed my location before the authenticator went live, but it’s still prompting me at every login. How can I fix this?

Organizer – Ex Cineribus
http://excineribus.dkpsystem.com

Authenticator bug [Merged]

in Account Issues

Posted by: Myrkaba.9643

Myrkaba.9643

I would like to second (or third) the ability to un-remember a location (sounds like it is in development). I remembered a few locations prior to the beta for the mobile-authenticator. I found the email verification to be a hassle (and it may be just me, but I don’t like clicking links in any email) but the mobile verification is now a natural part of my login. I’d like to echo the statement that some of us are scardypants and prefer to know that our login is secured (not just that it is secured, I’m not doubting that, but that we are made aware that it is secured by taking part in the process).

Would it be possible, in the meantime (until we have the UI to un-remember a location), to receive a message stating: “This login was secured by [mobile/email] authentication.” or something along those lines on the login page post authentication?

Thanks for the updates and the honesty, I forgive you this time.

Authenticator bug [Merged]

in Account Issues

Posted by: Teppo.9203

Teppo.9203

Personally, I’d like to have the option to always ask me for the 6 digit code regardless of where I go to log into my account.

Add me to the list of folks who chose to be paranoid. Would really like this feature.

Authenticator bug [Merged]

in Account Issues

Posted by: Arkronis.1576

Arkronis.1576

Personally, I’d like to have the option to always ask me for the 6 digit code regardless of where I go to log into my account.

Add me to the list of folks who chose to be paranoid. Would really like this feature.

Ditto – Very much prefer to use the Authentication as a step within my log in process.

Authenticator bug [Merged]

in Account Issues

Posted by: Zaken.1806

Zaken.1806

I agree. I would prefer the option to use the authenticator everytime I login. Although I can understand why some might want the option to skip that if they are logging in from the same IP.

Authenticator bug [Merged]

in Account Issues

Posted by: KZavi.9540

KZavi.9540

Phew… thanks for explaining the issue. No need to worry then
And I agree we need more options with the Authenticator.

Authenticator bug [Merged]

in Account Issues

Posted by: Rune Jairusion.4610

Rune Jairusion.4610

how do i turn on mobile authenticator?

Authenticator bug [Merged]

in Account Issues

Posted by: Zaken.1806

Zaken.1806

Authenticator bug [Merged]

in Account Issues

Posted by: ExtraPaleAle.8904

ExtraPaleAle.8904

i would also like to enter the code

Authenticator bug [Merged]

in Account Issues

Posted by: DJRiful.3749

DJRiful.3749

Hi all,

First and foremost: please be aware that your accounts are still protected by the mobile authenticator at this time.

Here’s what has happened:

- We have been developing a “remember this network” feature for the mobile authenticator in line with the same feature used by email authentication

- This feature became active tonight during the planned maintenance updates

- For any account which has already selected to remember a network, the mobile authenticator will respect your existing settings

- This means that if you are logging in from a location that you permitted via email authentication, the mobile authenticator will not currently prompt you for a secondary code

Your account is still covered by the authenticator for logins from unverified locations.

This is the result of an oversight on my part and I’d like to apologize for any uncertainty and worry. We’ve double checked the systems and authentication is working correctly for unverified logins.

Unlinking the authenticator was temporarily disabled due to a configuration accident; this has been corrected and should work again.

For the moment we do not have a user interface for editing your “remembered” network locations. As a result, please be very cautious when selecting to allow new locations from the emails (or, in the near future, from the mobile authenticator login screen).

Thanks for bearing with us while we get the rest of the mobile authenticator features ready to go.

Omg, thank you! I was so annoyed for each prompts.

Stormïe on Tarnished Coast [TMS] [CERN] [FILM]

Win 8 Pro | 3930k | 16GB | GTX TITAN | SSD | 1440p