Game Minimizes Randomly

Game Minimizes Randomly

in Tech Support

Posted by: Chev.1783

Chev.1783

The game has a tendency to minimize randomly. I have this issue as well as my girlfriend. I spoke with a guildie last night that has the same issue.

We think that it has to do with running multiple monitors. Whenever the game minimizes, our cursor ends up on the secondary monitor. Perhaps this is related, perhaps not. Either way, I would not consider this a normal function of the game.

Please fix this soon, as competative PvP become non-competative when you loose because the game minimizes.

Game Minimizes Randomly

in Tech Support

Posted by: Mr eX.3420

Mr eX.3420

I’m sporting a triple-monitor setup and I’ve had the same problem. For me, I have noticed that it’s always when I’m turning the camera. I’ll be holding down either left- or right-click and the game will minimize, and I’ll be drawing a selection box on my desktop.

Twitter: @mr_ex; IGN: Optimus Maleficus
Co-Leader, I Can Outtweet A Centaur! [TWIT]/#twitguild

Game Minimizes Randomly

in Tech Support

Posted by: zbrkesbr.4173

zbrkesbr.4173

use fullsceen windowed mode and you wont have such problem.

Game Minimizes Randomly

in Tech Support

Posted by: Chev.1783

Chev.1783

use fullsceen windowed mode and you wont have such problem.

Unacceptable.

Full screen windowed mode means, as I look for my poorly chosen colored mouse I have to check two monitors.

This is a simple requirement of full screen play. The game should not minimize without my explicit input.

Game Minimizes Randomly

in Tech Support

Posted by: Mr eX.3420

Mr eX.3420

My thoughts exactly. Windowed mode is a workaround, which I appreciate having, but it’s not a solution. I don’t want to see the taskbar or window border when playing a game.

Twitter: @mr_ex; IGN: Optimus Maleficus
Co-Leader, I Can Outtweet A Centaur! [TWIT]/#twitguild

Game Minimizes Randomly

in Tech Support

Posted by: zbrkesbr.4173

zbrkesbr.4173

My thoughts exactly. Windowed mode is a workaround, which I appreciate having, but it’s not a solution. I don’t want to see the taskbar or window border when playing a game.

You dont see those on main monitor if you use fullscreen windowed (unless you have “stay on top” checked for taskbar) and is convenient for you to use browser, chat and do other things on 2nd monitor as it doesnt minimize main on either alt tab or simply moving mouse to 2nd monitor. But that is my personal preferences, you might think otherwise.

War doesn’t determine who is right, only who is left.

Game Minimizes Randomly

in Tech Support

Posted by: Ulari.9547

Ulari.9547

I had a similar issue.

I am running two monitors (GW2 maximized on one). I found the cause was that I had Citrix processes running in the background and periodically they stole ‘focus’ from GW2 and I end up on my desktop. I had the same issues in WoW last year…

My solution was to go into Task Manager and disable all the Citrix processes (used for accessing my work network from home). I have Citrix set to launch on PC start-up so I go through this process whenever I am going to launch GW2.

Sorry if this is not helpful, figured I’d share just in case…. it did fix my issue in GW2 and WoW.

Ulari

Game Minimizes Randomly

in Tech Support

Posted by: RoyHarmon.5398

RoyHarmon.5398

I had a similar issue.

I am running two monitors (GW2 maximized on one). I found the cause was that I had Citrix processes running in the background and periodically they stole ‘focus’ from GW2 and I end up on my desktop. I had the same issues in WoW last year…

My solution was to go into Task Manager and disable all the Citrix processes (used for accessing my work network from home). I have Citrix set to launch on PC start-up so I go through this process whenever I am going to launch GW2.

Sorry if this is not helpful, figured I’d share just in case…. it did fix my issue in GW2 and WoW.

Ulari

You may find it more convenient to set up a shortcut for this.

Basically, you write a batch file to close the Citrix programs and launch GW2.exe.

It’s a combination of this link and this one.

What I’m thinking is something like this:
Create a text file in Notepad and insert the following (with file names/locations changed to suit your needs):

taskkill /im Citrix.exe (or whatever it’s called)
start "" “C:\Program Files (x86)\Guild Wars 2\Gw2.exe” (or wherever your Guild Wars 2 program is located)

If there are other processes you need to close, you can add them to a new “taskkill /im” line, and they should close properly if they’re running. And if they’re not, it should be fine.
When you’re done, save it on your desktop as something like “GW2.bat” so it’s executed as a batch file.

Then all you’ll have to do is double-click it to close Citrix and open GW2.

Game Minimizes Randomly

in Tech Support

Posted by: Miss Mindie.4976

Miss Mindie.4976

Just to add for those that aren’t aware, full screen windowed mode is an option within the game. It looks just like regular full screen, but you have access to your other monitors without the game minimizing when it loses focus.

Game Minimizes Randomly

in Tech Support

Posted by: Mr eX.3420

Mr eX.3420

Thank you all for the tips! I know I am running some Citrix stuff at home so that is probably to blame, I’ll have to make sure it’s not running when I don’t need it (95% of the time.)

Full screen windowed mode (now that I know what it is) sounds like something worth trying out. It might not work for me because I have some trouble with gamma/brightness on my main monitor and it does better with the game in proper fullscreen.

FWIW, I’ve been using alt+enter to switch between proper fullscreen mode and windowed mode when I need to interact with my other monitors. Cleaner than alt-tabbing because you can still see the game, and it takes about the same amount of time.

Twitter: @mr_ex; IGN: Optimus Maleficus
Co-Leader, I Can Outtweet A Centaur! [TWIT]/#twitguild

Game Minimizes Randomly

in Tech Support

Posted by: Chev.1783

Chev.1783

No citrix processes here.

Still having the problem on two machines without Citrix processes.

ANet? This does not happen in ANY steam game, GW1, or any other application I have running. How about a fix?

Game Minimizes Randomly

in Tech Support

Posted by: rgraze.5169

rgraze.5169

I am not running any citrix either. I am running a GTX680 with 3 monitors @ 5760×1200 in nvsurround and a 4th up top running various windows. Seems to happen more often when Im waiting for a dragon. Windowed mode is not an option in this setup.